首頁 > Python, uBuntu > 在現有Apache2再安裝新的module – mod_wsgi.so

在現有Apache2再安裝新的module – mod_wsgi.so

2010年2月12日 發表評論 閱讀評論

我在開發機上已經先安裝了Apache2,現在需要讓Python能在Apache上執行,得使用一個module,這裡使用wsgi這個module,但得手動make及install
底下是我的過程:

一、到wsgi官網下載wsgi的source code (我是下載現在的最新3.1版,不知道n年後會是更新到幾版^^)
在我的home目錄,執行 (就直接放在home目錄吧)


$ sudo -c wget http://modwsgi.googlecode.com/files/mod_wsgi-3.1.tar.gz

二、下載後,解壓縮:(我這裡會直接解到mod_wsgi-3.1目錄)

$ tar xvfz mod_wsgi-3.1.tar.gz

※注意唷,我現在是3.1,之後是多少~~不知道~~~

三、進入mod_wsgi-3.1目錄吧,要執行底下的指令來確認環境

$ ./configure

我會寫這篇,就是因為在這裡卡到了~,因為我出現一堆apxs找不到的錯誤訊息
上網再找,總算在Apache apxs這則討論找到解決的方法~

因為我是先安裝了Apache2,並沒有source code,所以wsgi在偵測環境時,沒有可用的原始檔
當然我也有用

sudo apt-cache search apxs

來看apxs會是在哪個pakage裡,但還是列了很多,不確定我該裝哪一個,索性還是照著Apache apxs這則討論直接安裝apache2-threaded-dev吧


$ sudo apt-get install apache2-threaded-dev

(老實說,我還沒找到這個安裝後是安裝到哪個位置,不管,晚一點再找吧~)

然後再回到我home下的mod_wsgi-3.1目錄
再次檢查wsgi需要的環境
這回就全找到了
沒有錯誤啦!!!

好,直接執行下面的指令吧

make

照手冊說就是Building The Source Code
但我執行後還沒看到mod_wsgi.so呀
因為,還需要安裝~~
正是底下的指令


$ sudo make install

記住,要以 root 的身份執行呀~

這時一切都ok了,剩下最後一步,讓Apache載入這個mod_wsgi!!

我的這個Apache2因為是安裝在uBuntu 9.10 desktop裡,在Apache的設定位置較不一樣
如下:

$ cd /etc/apache2/mods-available
$ sudo vim wsgi_module.load

然後編輯就是完全一樣的了

LoadModule wsgi_module /usr/lib/apache2/modules/mod_wsgi.so

這個mod_wsgi.so絕對位置,請依照實際情況給予正確的位置哦,可能不同的server,放的位置會不同吧~

$ cd /etc/apache2/mods-enabled
$ sudo ln -s ../mods-available/wsgi_module.load .

好了,再重啟一下Apache吧!!

sudo /etc/init.d/apache2 stop
sudo /etc/init.d/apache2 start

就OK了!!

之後,要再實做設定時,再把這篇補齊嘍~

Categories: Python, uBuntu Tags: , ,
  1. 目前尚無任何的評論。